Autoya by sassembla - 8

Frameworks

thin framework for Unity.

Unity 2019.2.21f1MIT LicenseUpdated 15 hours agoCreated on July 29th, 2016
Go to source

Autoya

loading

small, thin framework for Unity.
which contains essential game features.

Required

  • Unity 2018.x or later.
  • Scripting Runtime Version 4.6 Eq.

Document

gh-pages

Features

  • Authentication handling
  • AssetBundle load/management
  • HTTP/TCP/UDP Connection feature
  • Maintenance changed handling
  • Purchase/IAP feature
  • Notification(local/remote)
  • Information

Editor Features

  • AssetBundle build
  • link.xml generate

Motivation

Unity already contains these feature’s foundation, but actually we need more codes for using it in app.

This framework can help that.

License

see below.
LICENSE

Tests

implementing with Miyamasu test tool. see Assets/AuotyaTests/Tests folder.

Install

unitypackage is ready!

  1. add Purchase plugin via Unity Services before install Autoya.
  2. use Autoya.unitypackage.
  3. done!

or, use partial installer.

  1. use Autoya.X.unitypackage
  2. done!

then, type “Autoya.”. that’s all!

Usage

all example usage is in Assets/AutoyaSamples folder.

Show all projects by sassembla